ejmick

My feedback

  1. 286 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    65 comments  ·  Public » IP Phones  ·  Flag idea as inappropriate…  ·  Admin →
    ejmick supported this idea  · 
    An error occurred while saving the comment
    ejmick commented  · 

    I have also experienced this. Small deployment, 5 users, 3 Poly CCX phones. Calls run through Auto Attendant (for scheduling) then to Call Queue to ring all users (Attendant Routing). When phones are in place, call presentation is delayed 3-10 seconds. When answering the call from the client or phone, response is very sluggish in that audio doesn't cut through for a few seconds. When phones are removed and run as "client only", performance is much improved. Not perfect, but about as you would expect. Customer feels as though they gave it a shot, but wants to replace it with something else.
    As a partner looking to build a Teams Voice practice, this has us considering going back to our previous voice offerings. To Microsoft support's credit, they acknowledged this as a "known issue" and have engineers investigating a workaround and/or permanent fix. Hoping for a quick resolution to restore the faith.

  2. 133 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    16 comments  ·  Public » Calling  ·  Flag idea as inappropriate…  ·  Admin →
    ejmick supported this idea  · 
  3. 2,254 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    336 comments  ·  Public » Messaging  ·  Flag idea as inappropriate…  ·  Admin →
    ejmick supported this idea  · 

Feedback and Knowledge Base