How can we make Microsoft Teams better?

MAC app fails to update with standard account (needs admin creds)

On most Macs I’ve tried, the automatic update framework is pretty aggressive, and apparently cannot be unconfigured. However, it consistently fails to update the app when I’m logged in with a standard account. The app occasionally prompts for admin creds (I assume it’s making an update helper daemon), and I supply them, but the only Helper process Teams ever runs is owned by the standard account. I’m not sure exactly what to suggest here, because there are several opportunities for change, some of which might obviate usefulness of others. Ideas might be some user interaction to defer the forced relaunch during updates, options for scheduling deferred updates, options to manually supply admin credentials at each update, improve reliability around whatever helper proc is supposed to facilitate updates.

134 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Warren shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  Warren responded  · 

    Hi everyone,

    Wanted to let you know that a New Mac installer has released to the Public ring. It has a new auto-update mechanism and will no longer require an admin password for updating!

    Thank you for your support and feedback!
    -Warren

    32 comments

    Comments are closed
    • Andy McPherson commented  ·   ·  Flag as inappropriate

      Any updates on this? We've had to try and find a workaround to prevent Teams from trying and failing to update our standard users.

    • Michael Scroggins commented  ·   ·  Flag as inappropriate

      People have been complaining and pointing out this exact problem to your engineers for almost a year. We're asked to help you prioritize from a list of problems. This one overwhelmingly and unsurprisingly takes the cake, as, like was mentioned in the first place - this causes the other problems.

      So just to confirm - you released a broken product just to stay in the marketplace, and NOW your engineers understand that this is the root problem, after the admins who have been using it have been specifically pointing this exact thing out to them for almost an entire year.

      Meanwhile - shuffling around and manually deleting your **** pile of updates that just manifests in nested system folders. I hate to be unfair but this is really ridiculous. You have the resources to do this properly, you're choosing not to.

    • Josh commented  ·   ·  Flag as inappropriate

      Glad to hear this is being worked on. Teams has become unreliable as a communication tool as it never seems to be running when I need it.

    • John commented  ·   ·  Flag as inappropriate

      This has totally destroyed our aspiration to use teams instead of Slack and caused 100's of support tickets for using teams on macOS. Our user hate the constant admin prompts.

    • Jannik Nielsen commented  ·   ·  Flag as inappropriate

      @Adam Horner: did the focus stealing go away, when you installed the app in your local applications folder?

    • t commented  ·   ·  Flag as inappropriate

      Well something happened... the prompt has now changed to "incessant" notifications say (I paraphrase) "congrats on having the latest updated installed" - with no prompt.. So still aggressive... but no prompts to authenticate...

    • Michael Scroggins commented  ·   ·  Flag as inappropriate

      Perhaps an administrator build, in which auto-update is disabled, could be patched and given as a temporary work-around? At least in that case, we could push out the updates ourselves and they wouldn't have the minimizing/failed update cache/required admin credential pop ups hassling them while they're just trying to do their job. (And they might also actually be inclined to use Teams in the first place)

    • Michael Scroggins commented  ·   ·  Flag as inappropriate

      I feel like this is the root of all the other sub-problems. Deploying this for a large set of Mac users has been a NIGHTMARE, to the point that they would rather not even use it and just continue to opt for Slack.

      It seems that BECAUSE of the required admin creds for update, that's also why it keeps storing copies of the update file and never executes them, until it grows into a huge waste pile. I discovered this while running hard disk audits when people started sporadically getting low disk space messages - only to find that Teams update files were taking upwards of 60Gigs of their disk due to unsuccessful update attempts.

    • Adam Horner commented  ·   ·  Flag as inappropriate

      My challenge was definitely due to not having local admin rights. Instead of getting it installed in /Applications (which my IT did for me), I instead installed it in ~/Applications (i.e. in my home folder) and the app works as intended.

    • Anonymous commented  ·   ·  Flag as inappropriate

      This is still an ongoing issue and without any resolution, I'm looking into switching my team to a different tool, abandoning Teams altogether.

    • Anonymous commented  ·   ·  Flag as inappropriate

      The focus stealing is particularly annoying, it leads to numerous wrong window errors.

    • Ned Horvath commented  ·   ·  Flag as inappropriate

      I see a similar issue, apparently related to updates: the app steals focus from wherever I'm working, then minimizes the Teams window but leaves me in Teams (as evidenced by the menu bar). This is REALLY irritating when one is in the midst of interacting with some other app.

    • Teams-Flyer commented  ·   ·  Flag as inappropriate

      If you are working as normal user under MacOS Teams crashes and restarts all the time... If you gain Admistrative Rights on the Account the crashes immediately stop. Removing Administrative Rights and crashes start over.

      Because of the fact that many users on macs are working with administrative right enabled, i can imagine that not many people have this problem. We are using Macs inside an managed organisation without administratice user rights - we are running into this problem with all users within the organisation.

    • Adam Horner commented  ·   ·  Flag as inappropriate

      There are several other comments that are all the same issue, app minimising, app stealing focus, app restarting etc. This is truly annoying, destroys my flow when I'm working in a productivity app (like word) and really takes away from the usefulness of the app, it drives me to close it when I really should have it open to keep on top of my other team members' conversations.

    • Anonymous commented  ·   ·  Flag as inappropriate

      You folks closed the issue: https://microsoftteams.uservoice.com/forums/555103-public/suggestions/17613595-remove-the-need-to-constantly-log-in

      But this still is very much a problem at least in the mac client.

      I am constantly signed out of teams. This is silent so you don't even realize that you are signed out. This has led to my current workflow for using teams to be send an email to the person I want to talk to telling them to log into teams. And I pretty much have to do this multiple times a day.

      I'm not sure if this is because of something with my company's configuration (requires 2 factor auth if not on vpn) or something else, but it is very frustrating.

      I somewhat worked around this by setting it to email me all messages, but even this seems wonky and doesn't always email me.

      Teams is a messaging app that silently stops delivering messages. This is a fundamental problem and is very frustrating. It basically makes it unusable.

    • Anonymous commented  ·   ·  Flag as inappropriate

      This happens to me about 10-12 times a day too. Still no answer from the moderator???

    ← Previous 1

    Feedback and Knowledge Base