How can we make Microsoft Teams better?

Mac Version Isn't Sequential, Breaks Automation

Your current Mac version available for download as of Jan 25 2019 installs an app with version 1.00.21761.

The previous version was apparently 1.00.131953

While 1.00.21 is a higher version than 1.00.13 unfortunately for any software that take into account the entire version string (like automated updaters/patching tools) version 1.00.131953 is a whole 110,192 versions *ahead* of 1.00.21761 :-/

This leads to scenarios where Teams may auto-update itself to x.21761 but automated patching sees that the version is now below the x.131953 version in our software repository and so re-installs that version. A fun loop.

Then when we add .21761 to the repository it won't install over top because the repo version is now *lower* than the existing installation of .131953 on the workstations.

Please ensure for future versions you can keep the numbering actually in the same decimal range...

PS - Our workaround is to trim our version checking to look at just the first 10 chars of the app's version string but really, if you're going to have a version number in the multi-100Ks, please just ensure it's consistently in that range for each release!

2 votes
Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Matt shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Sign in with: Facebook Google
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base



You are about to visit the UserVoice site for Microsoft Teams

We have partnered with UserVoice, a 3rd party service providing public discussion forums for product-specific feedback.

By clicking "Continue to UserVoice" you agree to UserVoice's Privacy Policy and Terms of Use.