How can we make Microsoft Teams better?

Android - Calls should respect 'Do Not Disturb'

Current state (Android): Teams calls do not respect system 'Do Not Disturb'.

Steps to reproduce:
1) Enable 'Do Not Disturb' on an Android device running Teams
2) Call Android device from 2nd device - Teams will play a notification ringtone.

Expected result:
Teams should not play a notification ringtone when system 'Do Not Disturb' is enabled

20 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

4 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Karine Rivet commented  ·   ·  Flag as inappropriate

    I concur! This is a real issue that needs to be addressed! Teams completely ignores Android Do Not Disturb, and should absolutely be made to honor it. If my Android phone is in Do Not Disturb I should receive not Teams notifications at all.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Teams on android also does not follow the "silent" mode. Putting the phone into vibrate only does not silence the incoming calls notification.

  • David commented  ·   ·  Flag as inappropriate

    Woken up in the middle of the night even though Do Not Disturb is on and Calls only allowed from starred contacts and repeat callers.

    Especially annoying as voice mail is now enabled so I also got an email with a transcript!

    This is a YEAR later than the comment about and still Teams calls is not functional

  • Ian Latham commented  ·   ·  Flag as inappropriate

    Yea, failure to honor this worke me up early today due to a telemarketing call. Thanks. Uninstalling until this works as it should.

Feedback and Knowledge Base