How can we make Microsoft Teams better?

"Copy link" (aka permalink) doesn't work properly (bug)

I'm using Teams on a Mac.

Today I opened up Teams and was delighted to discover that there is now a "Copy link" option under the three-dot menu on each message. Unfortunately it doesn't work. Upon using it I would have expected to get a URL in my clipboard (pretty safe assumption for a menu item labelled "Copy link") but that's not what happened. Instead, this is what ended up in my clipboard:

Firstname lastname: Request you to add some links or documents regarding …
posted in Technology Communities/Tech Renewal General Ideas and Questions at 23 Mar 2018 04:44

I mean, come on. Seriously? What on earth is that? Its just some text that contains the first part of the message. Its not a URL. How you can mess up something so fundamental as a permalink is utterly beyond me.

I'm on a mac by the way. I tried using the "Copy link" feature at https://teams.microsoft.com in Chrome and the same thing happened.

Please pease please fix this.

49 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Jamie Thomson shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

22 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Sandra commented  ·   ·  Flag as inappropriate

    When pasting this "link" into a powerpoint, you have to click Insert link and build it that way - which is NOT user friendly or intuitive especially when I can copy the URL for google and simply right click paste and the link is created. Please fix this. It is the everyday issues like this that frustrates our user community and creates bad user experiences with Microsoft.

  • Nithya ramakrishnan commented  ·   ·  Flag as inappropriate

    Any updates on why the copy link to tab opens the Conversation Tab in browser instead of opening the Tab itself. This seems to be a recent issue.

  • Anonymous commented  ·   ·  Flag as inappropriate

    With the PC app, copy link to tab is not working. It copies a URL, but this URL directs to the "conversation" tab every time, not the tab that was open when the URL was copied

  • Jamie Thomson commented  ·   ·  Flag as inappropriate

    hold on... looks like the old behaviour has returned. Just tried it on the desktop app on mac and my clipboard contains all the extra gubbins as reported before. All I want is the URL.

    Its exasperating that just a few days ago I had a version of the desktop app that didn't exhibit this behaviour and now I've got a version in which its returned. I harbour hopes that in the long term this will be fixed. Permanently.

    My current version of the mac desktop app is by the way. Here's what it says in About>Version:

    You have Microsoft Teams Version 1.1.00.31953. It was last updated on 07/12/2018.

    I've just checked on iOS and it looks like the proper behaviour (i.e. clipboard only contains the URL) is still in place which is good news.

  • Jamie Thomson commented  ·   ·  Flag as inappropriate

    Just tried this in the desktop app on mac and it looks like its fixed. The only thing in my clipboard after clicking "Copy link" was the URL. Nothing else.

    Tried it on mobile too, same behaviour there.

    Great news. Thanks for fixing.

  • Josh commented  ·   ·  Flag as inappropriate

    On mobile I expect to be able to long press any link and choose copy. But currently I don't get any kind of context menu so I cannot copy links on mobile.

  • Josh Stout commented  ·   ·  Flag as inappropriate

    How can people invite external entities if they can't copy paste a link to them quickly? every other client when you copy link copies plaintext into the clipboard so supporting pasting to anything... please fix this

  • Anonymous commented  ·   ·  Flag as inappropriate

    Sorry, but not being able to send a link to an item in my channel is simply not acceptable. Come on - this is the most simple case of collaboration.

  • Fran commented  ·   ·  Flag as inappropriate

    Same happens to me and I am not using a Mac. It looks like the Teams link can only be used in Teams, as I copied a link to a post and send it via chat to a colleague. But if you try to share/reference that link outside of Teams it won't work.

  • Ulf commented  ·   ·  Flag as inappropriate

    Yeah, the feature is implemented so we can praise ourselves! But that it's not working in almost all use cases is just a bug we'll fix eventually, no biggie, har har :-(

  • Anonymous commented  ·   ·  Flag as inappropriate

    When users go to the ellipse menu on a file in the Files tab and select Get Link, if they select Microsoft Teams (the default option) the URL is huge, messy and...

    ...multiple user are reporting it doesn't work when inserted in emails or channel or chat conversations. Testing validated this...

    We've told users to select SharePoint instead to get a cleaner URL that seems to be working reliably. But this is not intuitive as Microsoft Teams is the default selection.

    Is this a bug or poor UX? If there are specific reasons to select one link type vs. the other, can we add that language to the dialog box. (Though, I can't find a reason to use the Microsoft Teams link since it doesn't work every time.)

  • Jamie Thomson commented  ·   ·  Flag as inappropriate

    Glad to see this has made it onto the backlog.

    Commenter Andrew has it spot on with " oblivious to how the web works"

  • Andrew ​ commented  ·   ·  Flag as inappropriate

    I cannot fathom how Microsoft so badly failed to understand such a simple feature. It's like they exist in another universe, oblivious to how the web works.

  • Phillip Kent commented  ·   ·  Flag as inappropriate

    It does work, but Copy Link puts into the clipboard a link object, not a URL. So if you paste it into a plain text field then the URL gets lost.

    There is a UI consistency issue since 'Get link' for a channel or team puts just a URL into the clipboard

  • Tuure Laurinolli commented  ·   ·  Flag as inappropriate

    To clarify, I would expect to get a URL that can be clicked to open the conversation in question instead of a text snippet.

  • Tuure Laurinolli commented  ·   ·  Flag as inappropriate

    When I select "Copy link", I get "Copied to clipboard" notification. When I then try to paste the link to e.g. JIRA, only text is pasted, like: "Person A: Person B and Person C - please can you remind me what we …
    posted in Our Team / Some Channel at Apr 17, 2018 3:23 PM"

  • Davorak commented  ·   ·  Flag as inappropriate

    The issue is that what is copied to the clipboard is html.

    So if you paste somewhere that excepts the html you can extract the actual link.

    Places I want to paste links that do not work with html formating

    * jira
    * text only email
    * github
    * gitlab
    * text editor

← Previous 1

Feedback and Knowledge Base