How can we make Microsoft Teams better?

Do Not Disturb unexpectedly changes to Available

I set myself to "Do Not Disturb"
I send a message or a chat.
Teams decides I'm available, and changes me to "Available."
NO, DND means JUST THAT. Please STOP changing my availability!

161 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Delia D shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    Once your tenant is using UPS (unified presence service), you should no longer have issues where DND changes back to available.

    If you are on UPS, and are experiencing this issue, it would be super helpful if you can capture logs by typing Ctrl + Shift + Alt + 1, and send the file from your downloads folder along with any details to teamsml@microsoft.com.

    Thanks all!

    37 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  ·   ·  Flag as inappropriate

        Its funny I just spent an hour on the phone with support and they said they have never seen this issue.

        Apparently I am not the only one. Pathetic.

      • Edwin commented  ·   ·  Flag as inappropriate

        Same. Still happening to me as of today. This is ridiculously stupid. Busy and DND status should never change on its own.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Mine does the opposite. It changes without warning to DND, and then no one can reach me.

      • JK commented  ·   ·  Flag as inappropriate

        Still happens for me on Mac. "You have Microsoft Teams Version 1.1.00.11551. It was last updated on 5/7/18."

      • Anonymous commented  ·   ·  Flag as inappropriate

        Any updates on this? This is working in skype for business, why isn't it working in Teams?
        This is basic functionality!!

      • K commented  ·   ·  Flag as inappropriate

        This post was published ... May 04, 2017.

        It is now May 30, 2018... more than a year later. Hello Microsoft

      • Anonymous commented  ·   ·  Flag as inappropriate

        This application is a horrible, horrible joke- how hard is it to set something to DO NOT DISTURB?!

      • Jason commented  ·   ·  Flag as inappropriate

        Even with the latest status integrations/updates, this is still happening. I set both Skype (consumer) and Teams to DND when I went into a meeting, and when I checked Skype was still DND, even though I had opened it, while Teams was green again. It should never, ever go off DND unless it's scheduled or I manually change it. I thought this was being fixed as part of the S4B status integration - I would hardly call that complete until this is fixed.

      • [Deleted User] commented  ·   ·  Flag as inappropriate

        I can confirm Teams changes Status even when my account is logged in after it was Locked. Please fix it.

      • Anon commented  ·   ·  Flag as inappropriate

        This is the biggest joke about this awful application. Why should anything at all change your status from DND? DND literally means 'do not disturb me'! It will often just go back to available with just having the teams window open and no new messages etc. Minimising it seems to stave it off for longer.

      • Mark Fly commented  ·   ·  Flag as inappropriate

        This happens to our entire team and is so frustrating many turn Teams off during meetings, etc. Which then is often forgotten and left turned off. Is this even being addressed as a bug? Or is this what is considered a feature to turn on automatically...? If so baed on what?

      • Steve commented  ·   ·  Flag as inappropriate

        While entering the issue here today, it reset me again. (3/29/2018). I will send logs from today. This is very frustrating as I need the same functionality that is in SfB.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Having this problem today (3/27/18) while running Microsoft Teams Version 1.1.00.5963 (64-bit). It was last updated on 3/15/18. This is running on Windows 10 Enterprise version1607

      • Anonymous commented  ·   ·  Flag as inappropriate

        This is happening to me on Windows 8.1, no idea what version of Teams I have, but it should be up to date as of 14/03. I don't need any kind of network blip - I set myself to DND, and several seconds later the icon changes, and then changes back as soon as I touch the computer again. It's a basic feature, and a shame it simply doesn't work.

      • Mark Piper commented  ·   ·  Flag as inappropriate

        MacOS 10.13.3
        Teams 1.1.00.5851

        Similarly to the last poster, it firstly takes a bafflingly long time (10-20 seconds) to actually show the red badge after selecting DnD.

        Secondly, I can reliably recreate the issue by causing a network blip of sorts - switching wifi on and off, or simply connecting/disconnecting a VPN. From the logs, the app seems to be doing a network check, which briefly fails when switching network. When the app then deems there to be a network connection again, it sets my status back to Available.

        Screen cap and logs sent

      • Ludwig commented  ·   ·  Flag as inappropriate

        I sent the logs but here are the report steps that work every time :

        Desktop MacOS version 10.12.6 (16G1036)
        Teams version: Y1.1.00.5851.

        Change Settings to Do Not Disturb
        Wait 3-10 seconds for the icon to change
        Put Computer into sleep mode for 3-5 seconds
        Wake computer
        Observe : You are now available

        As you computer will typically go to sleep many times a day while you are away from your desk this is a fairly annoying issue. Other conditions also seem to change your status from DND but they are hard to repro.

      ← Previous 1

      Feedback and Knowledge Base