How can we make Microsoft Teams better?

Bug: Teams restarts several times a day

Teams restarts several times a day, it says a new update has been installed. I think something goes wrong with installing the update and then it tries the same an hour later.

I run Teams as a standard user (non admin), maybe it doesn't have enough priveledges to successfully finish the update?

Please fix.

112 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    52 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Dave Lucre commented  ·   ·  Flag as inappropriate

        Same issue here, although often it will also steal focus from whatever application I am working in. I see the Teams tray icon appear, and then moments later it gets hidden again (as it should be), I know Teams is the culprit as it has happened too many times in the short time I have had it installed for it to be anything else.

        While only an annoyance, I can't justify a rollout to my users with the Teams client restarting many times per day, and stealing focus from the active application.

        This must be fixed.

      • Bradey Klein commented  ·   ·  Flag as inappropriate

        same issue here, both at work and at home. Linux version of teams is much more stable (and more limited)

      • Anonymous commented  ·   ·  Flag as inappropriate

        Has this gotten any sort of response from anyone on the Teams team? There's something really wacky going on with the way Teams gets installed... The constant restarts make the app almost unusable.

      • L Smith commented  ·   ·  Flag as inappropriate

        croswell's comment is accurate for my case as well. Updates download to the stage directory but executables in the current directory are locked by system. I've been able to upgrade by reinstalling Teams completely, but it breaks again at the next update. I have also uninstalled, rebooted to clear the file lock, deleted all files, and reinstalled, but it is not a permanent fix either.

      • Rebecca commented  ·   ·  Flag as inappropriate

        Mine keeps restarting too.
        "We ran into a problem. Reconnecting..."
        I've just upgraded to 1809

      • Anonymous commented  ·   ·  Flag as inappropriate

        So the Update.exe and Teams.exe are locked by a low level System PID? That's crazy. I can't update the app because of that. Why would this be locked by the System process?

        I'm able to work around it for a little while by manually uninstalling Teams (possibly restarting) and then re-installing the latest version. But that's not a great workaround. These files shouldn't be locked by the low level System process for any reason I can see.

      • csrowell commented  ·   ·  Flag as inappropriate

        I found the new version installed to %localappdata%\Microsoft\Teams\stage\Teams.exe. The version at %localappdata%\Microsoft\Teams\current\Teams.exe can't be deleted - Windows says it is being locked by "System" if you try to rename or delete it manually. This is backed up by the the %localappdata%\Microsoft\Teams\SquirrelSetup.log file which says "Failed to copy directories. Ignoring the exception and launching app from current directory. Exception = 'Access to the path 'C:\Users\first.last\AppData\Local\Microsoft\Teams\current' is denied.'". At any rate, I ran the application from the stage directory and now I am on the updated version. Hopefully a reboot later will resolve the file lock and it can officially update.

      • L Smith commented  ·   ·  Flag as inappropriate

        I've uninstalled, cleared out old files, and reinstalled several times. I am able to freshly install the latest version, but as soon as an update comes out, it restarts a dozen times a day, each time reporting that it has the latest, but the logs report a failed installation. i've been on 1.1.00.24759 for a couple weeks.

      • Michael Gelz commented  ·   ·  Flag as inappropriate

        I probably found the reason for this. I tried to fully uninstall Teams and checked in my user profile if there are any left overs. There was a directory in AppData\Local\Microsoft\Teams the folder structure "_previous\resources\assets" which were still there and I could not delete by myself, even not with admin rights.
        In File Explorer, I right-clicked the drive, then selected "Properties". Under the "Tools" tab, clicked "Check" inside the "Error Checking" box.

        It found some issues and one of them was exactly this folder:
        Found 2 missing entries (\Users\XXXXX\AppData\Local\Microsoft\Teams\_previous\resources\assets\Error-Systray16x16@2x.png <0x49,0x24bf2>, ...) in index "$I30" of directory "\Users\XXXXX\AppData\Local\Microsoft\Teams\_previous\resources\assets <0x18,0x24773>"
        ... repaired online.

        I could update properly now from Teams Version 1.1.00.19257 (64-bit) to 1.1.00.22960 (64-bit). Let's see if that keeps stable now.

      • Michael Gelz commented  ·   ·  Flag as inappropriate

        I have the same issue with version 1.1.00.19257 (64-bit). It restarts several times a day. When I check the version, I see "You have Microsoft Teams Version 1.1.00.19257 (64-bit). It was last updated on 8/31/18." And I have the same version now for 3 days in a row, but it always says it got updated.

        This is annoying, please fix it!

      • Stephen Lynch commented  ·   ·  Flag as inappropriate

        Every hour it restarts and fails to update.

        Mon Jul 02 2018 07:06:18 GMT+0100 (GMT Daylight Time) <1540> -- event -- name: desktop_update_exceed_success_attempts, previousUpdateUrl: https://statics.teams.microsoft.com/production-windows-x64/1.1.00.16255/Teams-1.1.00.16255-full.nupkg, previousUpdateVersion: 1.1.00.14359, previousUpdateTime: 1530511279008,
        Mon Jul 02 2018 07:06:18 GMT+0100 (GMT Daylight Time) <1540> -- error -- UpdateInfo: attempted to update 3 times but still on app version 1.1.00.14359

      • Anton Antonov commented  ·   ·  Flag as inappropriate

        I have noticed that after manual upgrade to 1.1.00.16255 the app crashes and downgrades to 1.1.00.13555

      • Anonymous commented  ·   ·  Flag as inappropriate

        After manual installation on Mac issue has been fixed ,now teams repeatedly asking for login when we switch to other window

      • Jeff L commented  ·   ·  Flag as inappropriate

        My Teams on both the mobile and desktop app revert to the default color scheme. On desktop it continually restarts and freezes with the message stating that there was a glitch. I have full permissions on this system but have to resort to mobile to actually communicate...

      • J.R. commented  ·   ·  Flag as inappropriate

        Had this happening starting 3/7/2018. I was running v1.1.00.2251.
        The fix I did was to manually install the v1.1.00.5855 version by logging into https://teams.microsoft.com, clicking on my profile picture, and selecting "Download the desktop app". So far so good.

      ← Previous 1 3

      Feedback and Knowledge Base