How can we make Microsoft Teams better?

Stuck in a login loop after password change

I recently change my system password, with MS Teams is already up and running in the background. I open Teams to check new messages, and it locks the app with the pop up "Can you please sign in again? Sorry for any inconvenience. Login Now"

I click Login Now but all it does is restarting MS Teams and show me the same message. I am unable to re-authenticate. I've tried restarting the application, that didn't work.

I had to right click on the systray icon to logout and re-login. I should be able to re-login when the app prompted "Login Now"

168 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Karis Ng shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    83 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • JC commented  ·   ·  Flag as inappropriate

        right-click sys tray app
        sign out
        WAIT!!!
        launch and be prompted

      • Colin Cogle commented  ·   ·  Flag as inappropriate

        Seriously. They want to replace the stable Skype for Business with this? I want to love Teams, but it and Planner haven't gotten a feature update since I started using it. Ditch the Electron garbage and make Teams a native UWP app and maybe things may improve.

      • Rob McLachlan commented  ·   ·  Flag as inappropriate

        For Windows users try this once you are stuck on the Sign In prompt:

        - Find the Teams icon on the right side of the taskbar (click the ^ icon)
        - Right click Teams and select Sign Out
        - WAIT! Teams should now quit (eventually).
        - If Teams does not quit itself, go to Task Manager (Ctrl-Shift-Esc) and select End Task on Teams
        - Restart Teams
        - You should now be presented with the MS account Sign In page where you can enter your email address and new password.

        This worked for me without deleting credentials etc. I also re-signed in on the web based teams.microsoft.com while trying this, so this may be a necessary step.

      • michael m commented  ·   ·  Flag as inappropriate

        pathetic - i have no log out option, have tried the things listed below, none worked. I don't get the login screen, just a blank purple screen, then it gives me a link and suggest i use it to logout and back in - but clicking on that just repeats the cycle! such low quality work

        my company forces password reset every 60 days, so once i figure this out, will have to do this again soon.

      • Sherman Woo commented  ·   ·  Flag as inappropriate

        For macOS users: if you are stuck in a loop for whatever reason (mine was because I tried to use a different tenant, and for some other reason it failed), let Teams load up and wait for the "sign in failed" screen. Right-click the Teams icon on the Dock and select Logout. Next launch, you'll be prompted to sign in again.

      • Ramesh Hemlock commented  ·   ·  Flag as inappropriate

        1. Right side Taskbar -> Click show hidden icons.
        2. You will see Teams icon and right click Teams -> Logout and then try to login.

      • Kathleen commented  ·   ·  Flag as inappropriate

        More MS fun! How about you guys fix this? Here is how I fixed it. If you have Teams running in more than one place, you get into that loop. Log out of everywhere you have Teams running and you will be prompted to enter your new password.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Changed my Windows 10 domain password this morning, now I'm trapped in this very same loop. Pretty ridiculous design flaw.

      • Anonymous commented  ·   ·  Flag as inappropriate

        i've deleted the msteams credentials, i've uninstalled teams. i can't re-install because it gets stuck "Go ahead and sign in..." splash - so frustrating

      • Anonymous commented  ·   ·  Flag as inappropriate

        OK, to fix this I had to right click the icon on the task bar, and choose log out. It took about 5 times of doing this before it worked and really logged me out.

      • Mike commented  ·   ·  Flag as inappropriate

        I'm having this problem right now. Just changed my password and now Teams is telling me:
        We need you to sign in! Either your password changed or the server needs your sign-in info again.

        I click the Sign in button and Teams goes away. A few seconds later it opens up again and I'm at the same error/prompt window.

      • Richard G commented  ·   ·  Flag as inappropriate

        I had the same thing after changing my company password, I rebooted my laptop and then it worked with no problem. Not a very good solution, the endless loop thing is ridiculous and a sign of poor programming.

      • Jeff commented  ·   ·  Flag as inappropriate

        New laptop, went to login via Google Chrome to download teams... when logging in I get a login loop.

      • bbbb commented  ·   ·  Flag as inappropriate

        This is an absolutely ridiculous error, and is occurring to me now. Right-click > Log Out from the taskbar doesn't work. Clicking Sign In (assuming it'd prompt for user/password) doesn't work. Quitting and restarting the program doesn't work.

        Fortunately, the suggestion to delete entries in Credential Manager did work - but who knows what other effects deleting 22 entries there will have?

        This is software you want people to take seriously as a Slack competitor?

      • DD commented  ·   ·  Flag as inappropriate

        Ji's solution unblocked me; kill teams, nuke all the credentials in the Credential Manager that have "msteam" somewhere in the name, re-launch teams, and then you can sign back in.

      • Dragan Babovic commented  ·   ·  Flag as inappropriate

        I hate Microsoft deeply and steadfastly. Unfortunately I have to use Teams at my work, and I can't sign in on Android after changing my domain password. I am afraid to do anything on Win 10 because I can lose it there as well. This is one piece of garbage.

      • Alyssa T commented  ·   ·  Flag as inappropriate

        I am not using the client app and am having the same problem with the web login. I cleared all credentials from browser and credential manager, cleared cache, and other basic troubleshooting. I eventually rebuilt my local profile on the PC and still I am not able to log into teams. Are there any registry keys or is there a hidden config file or something that I can remove or fix?

      ← Previous 1 3 4 5

      Feedback and Knowledge Base