How can we make Microsoft Teams better?

Configure app start up behavior

It would be great if I can decide how the app starts up, like start up at boot but minimized, start up at boot maximized, do not start up at boot, etc..

443 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Dave shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    Hey folks, is this still not working for you? We pushed an update that may have fixed it. Please log in/out, then select one of the start up config options, then see if it works for you when you launch again. If it does NOT, then please email me your user logs. You can find them here:

    C:\Users\YOUR NAME\AppData\Roaming\Microsoft\Teams

    My email address is sparavi (at) Microsoft (dot) com. I’m sorry this is causing such a hassle for you all! We’ll get it fixed, I promise.

    Sincerely,
    Suphatra

    102 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Pete commented  ·   ·  Flag as inappropriate

        I'm still unable to get Teams to auto-start. In settings I have ticked "Auto-start" and "Open application in background" and "On close, keep application running".

        I'm running version 1.0.00.34151 (64 bit), updated 15/12/2017 on a Windows 10 desktop.

        If I forget to open Teams in the morning, I only realise I'm missing messages when I get email notifications that I'm "missing all the action"...

      • Jose segura commented  ·   ·  Flag as inappropriate

        We would like to install Microsoft Teams for all users on a computer and not have it auto-start by default. Currently the Teams app has to be installed for each user than it defaults to auto-start. If we delete the auto-start key from the HKEY Local User then it is recreated anytime a user opens the app. Please stop forcing users to have the app open up by default.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I have the same problem. Have the box checked but it still doesn´t start automaticly.

      • Eric Renken commented  ·   ·  Flag as inappropriate

        Would love an option to start and either enter a named meeting in a channel enter that channel and create that named meeting.

      • Lesly commented  ·   ·  Flag as inappropriate

        Still an issue here too. I have the box checked for auto-start application, but still doesn't launch upon startup. Using Win10 as well.

      • Gav commented  ·   ·  Flag as inappropriate

        This is the most annoying piece of software I've ever had to install. Just fix the f**kin maximised screen at launch!! How hard can it be. Jesus christ.

      • James commented  ·   ·  Flag as inappropriate

        Can confirm this is still an issue. I have the "auto-start application" boxed checked, yet it still doesn't startup on windows. Using Win10, domain environment with latest updates completed.

      • Brent Watson commented  ·   ·  Flag as inappropriate

        Teams is set to load / run at boot, but it will not even do that. I have to manually start it.
        I would like it to load/run at boot and minimise

      • RogerB commented  ·   ·  Flag as inappropriate

        I want to start the app minimized.... and, if it is in system tray and I receive a chat, and I don't respond to the pop-up, promote itself to the app bar and blink the icon!!! .... if you miss the pop-up, you have no indication that anything has happened!!!!

      • Steve Bumba commented  ·   ·  Flag as inappropriate

        On mac, the app starts at full screen. Is this supposed to be configurable? I have a large monitor and it's really annoying to startup at full screen every time. Can it remember the last window size or be configurable?

      • Jason commented  ·   ·  Flag as inappropriate

        Changed the setting and then after a windows reboot the app starts in the background with no splash screen. Thank you for making this work correctly.

        You have Microsoft Teams Version 1.0.00.22051 (64-bit). It was last updated on 8/14/17.

      • Andrew commented  ·   ·  Flag as inappropriate

        Working for me (as of today anyway).
        You have Microsoft Teams Version 1.0.00.17151 (32-bit). It was last updated on 7/17/17.

      • Scott A. commented  ·   ·  Flag as inappropriate

        June 6th, and this is still not working correctly, plus, now Teams just restarts about ten times per day, so now the splash screen, and then the app, just pops up on my screen at random times and I have no control over it.

        Glad you chose Electron yet? Sigh.

      • David Topping commented  ·   ·  Flag as inappropriate

        I agree with Antoine - a recent update to the Windows version of the Teams client apparently fixed the issue with the "Open Application in Background" not behaving as one would expect. Thanks for the fix, whoever got it accomplished.

      • Chris Pearce commented  ·   ·  Flag as inappropriate

        Microsoft Teams does not start up minimised in macOS even when the startup hidden option is selected in the Login preferences section of macOS

      • Antoine Heskia commented  ·   ·  Flag as inappropriate

        The application has been updated on my computer on May, 13th and it seems that the application startup is now working as expected. It is minimized in the systray...The version is 1.0.00.1352 (64 bits)
        There is no release notes regarding this version so I do not know if this is a real fix...

      ← Previous 1 3 4 5 6

      Feedback and Knowledge Base